npm install && npm run dev が失敗したときの解決方法

環境

  • laravel Laravel Framework 6.6.2
  • node.js v6.17.1
  • npm 3.10.10

つまったところ

npm install && npm run dev を実行して、下記のエラー発生。

ValidationError: Invalid options object. Sass Loader has been initialized using an options object that does not match the API schema.
 - options has an unknown property 'outputStyle'. These properties are valid:
   object { implementation?, sassOptions?, prependData?, sourceMap?, webpackImporter? }

解決した方法

sass-loader をダウングレードしたら解決できました。

laravelのプロジェクトルートにあるpackage.json内のsass-loaderのバージョンをダウングレードしてください。
私は、”^8.0.0″→”^7.1.0″としました。

変更した後、npm install && npm run devを実行すればエラー無くなりました。

{
    "private": true,
    "scripts": {
        "dev": "npm run development",
        "development": "cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js",
        "watch": "npm run development -- --watch",
        "watch-poll": "npm run watch -- --watch-poll",
        "hot": "cross-env NODE_ENV=development node_modules/webpack-dev-server/bin/webpack-dev-server.js --inline --hot --config=node_modules/laravel-mix/setup/webpack.config.js",
        "prod": "npm run production",
        "production": "cross-env NODE_ENV=production node_modules/webpack/bin/webpack.js --no-progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js"
    },
    "devDependencies": {
        "axios": "^0.19",
        "bootstrap": "^4.0.0",
        "cross-env": "^5.1",
        "jquery": "^3.2",
        "laravel-mix": "^4.0.7",
        "lodash": "^4.17.13",
        "popper.js": "^1.12",
        "resolve-url-loader": "^2.3.1",
        "sass": "^1.20.1",
        "sass-loader": "^7.1.0",
        "vue": "^2.5.17",
        "vue-template-compiler": "^2.6.10"
    }
}

参考

https://programing-school.work/laravel-vue-js-dont-work/

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です